Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\

Перелік питань, що вивчаються. Створення і заповнення бази даних. Об'єкти бази даних База даних


Скачать 27.63 Kb.
НазваниеПерелік питань, що вивчаються. Створення і заповнення бази даних. Об'єкти бази даних База даних
Размер27.63 Kb.
ТипДокументы




Тема: Вікно MS Access. Структура бази даних в Access. Порядок проектування бази даних. Створення нової бази даних за шаблоном.

Мета: ознайомлення з вікном Access, порядком проектування бази даних та створення бази даних за шаблоном.

Перелік питань, що вивчаються.

1. Створення і заповнення бази даних. Об'єкти бази даних

База даних - це сукупність структурованих взаємозалежних даних, призначена для забезпечення інформаційних запитів у визначеній предметній області.

СУБД Access дозволяє керувати всіма відомостями з одного файлу бази даних, що містить всі об'єкти бази даних. Об'єкти - це компоненти, що використовуються для збереження і представлення даних.

Таблиця - це об'єкт, що використовується для збереження даних. Кожна таблиця містить у собі інформацію про об'єкт визначеного типу.




^ Таблиця містить поля (стовпці), у яких зберігаються різного роду дані, і записи (рядки). Для зв'язування відомостей, що зберігаються в різних таблицях, кожна таблиця бази даних повинна містити поля чи набір полів, що однозначно визначають кожен запис. Таке поле чи набір полів називають первинним (головним) ключем. Первинний ключ не допускає невизначених значень і завжди повинен мати унікальний індекс. Первинний ключ використовується для зв'язування таблиці з зовнішніми (вторинними) ключами в інших таблицях. У Microsoft Access можна виділити три типи ключових полів: счетчик, простой ключ і составной.

Форма - це об'єкт, призначений в основному для введення даних, відображення їх на екрані чи керування роботою додатка.



Запит - це об'єкт, що дозволяє користувачу одержати потрібні дані з однієї чи декількох таблиць.



Звіт - це об'єкт, призначений для створення документа, що згодом може бути роздрукований чи включений у документ іншого додатка.


^ 2. Запуск Microsoft Access 2000

Щоб запустити Microsoft Access треба:

  1. клацнути на кнопці 'Пуск' у панелі задач;

  2. вибрати

    • у стартовому меню рядок Программы;

    • у меню програм - Microsoft Access;

  3. клацнути на ярлику Microsoft Access на робочому столі (якщо на робочий стіл комп'ютера винесений ярлик Microsoft Access 2000);

  4. клацнути на кнопці Microsoft Access у панелі Microsoft Office (якщо на комп'ютері встановлений повний комплект Microsoft Office 2000).

У результаті виконання цих дій відкриється вікно додатка ^ Microsoft Access, у якому з'явиться вступне діалогове вікно 'Microsoft Access', що містить три кнопки перемикача.




Для продовження роботи треба:

  1. вибрати один з перемикачів:
    Новая база данных,
    Мастера, страницы и проекти баз данных,
    Открыть базу данных
    ;

    • перемикач Новая база данних дозволяє створити порожню базу даних, а потім додати в неї таблиці, форми, звіти й інші об'єкти;

    • перемикач Мастера, страницы и проекти баз данных дозволяє створити за допомогою майстра базу даних визначеного типу з усіма необхідними таблицями, формами і звітами;

    • перемикач Открыть базу данных дозволяє відкрити існуючу базу зі списку.

  2. клацнути на кнопці 'ОК'.


^ 3. Створення бази даних без допомоги "Майстра"

При запуску Microsoft Access 2000 (далі Access) відкривається діалогове вікно, у якому пропонується створення бази даних за допомогою майстра і створення порожньої бази даних.

Для створення бази даних без допомоги "Майстра" треба:

  1. вибрати в діалоговому вікні 'Microsoft Access' перемикач
    Новая база данных і клацнути на кнопці 'ОК';

  2. ввести ім'я бази даних у поле Імя файла: у діалоговому вікні
    'Файл новой бази данных'
    ;

  3. клацнути на кнопці 'Создать' чи натиснути клавішу Enter.
    У результаті виконання цих дій у вікні додатка відобразиться вікно бази даних і буде створена порожня база даних. Далі варто створити об'єкти цієї бази даних: таблиці, форми, звіти і запити, використовуючи послуги "Майстра" чи "Конструктора".




^ 4. Елементи додатка і вікна бази даних

Панель інструментів, рядок меню і контекстні меню додатка Access дозволяють організувати команди таким чином, щоб їх можна було швидко знайти і зручно використовувати.

  • убудований рядок меню за замовчуванням відображається у верхній частині екрана і містить стандартні пункти меню, такі як Файл, Правка, Вид та ін;

  • панелі інструментів можуть містити тільки кнопки, тільки меню чи сполучення кнопок і меню.

Так само як і інші додатки Microsoft Office 2000, Access 2000 автоматично набудовує меню і панелі інструментів під конкретного користувача на основі того, як часто використовуються ті чи інші команди.

Для створення і настроювання панелей інструментів, рядків меню треба:

  1. вибрати команду Панели інструментов у меню Вид і потім команду Настройка...;

  2. задати параметри, що впливають на вид і роботу панелей інструментів і меню, у діалоговому вікні 'Настройка';

  3. клацнути на кнопці 'ОК'.

Вікно бази даних забезпечує широкі можливості перегляду і керування об'єктами бази даних.

  • панель інструментів вікна бази даних дозволяє швидко знаходити команди для створення, відкриття чи керування об'єктами бази даних;

  • кнопка 'Объекты' служить для перегляду об'єктів бази даних на панели Объектов, вертикальна орієнтація якої зручна для використання;

  • кнопка 'Группы' служить для перегляду груп, у які можна включати ярлики об'єктів бази даних різних типів;

  • ярлики - режими створення використовуються для швидкого створення об'єктів бази даних за допомогою 'Майстра' чи для відкриття нових об'єктів у режимі 'Конструктора' з вікна бази даних;

  • у рядку стану відображається стан об'єкта.


Для зміни представлення об'єктів у вікні бази даних треба:

  1. клацнути на одній з наступних кнопок на панелі інструментів вікна бази даних: , , чи .

  2. вибрати команду Упорядочить значки в меню Вид і одну з наступних підкоманд: по імені, по типу, по даті створення чи по даті зміни.

Режими роботи
В Access розрізняються наступні основні режими роботи:

  • 'Таблица' - режим роботи з таблицею;

  • 'Запрос' - режим роботи з запитами;

  • 'Форма' - режим роботи з формами;

  • 'Отчет' - режим роботи зі звітами.

У кожному з названих режимів є підрежими: 'Просмотр', 'Конструктор' і 'Создать'. Наприклад, у режимі 'Таблица - Просмотр' можна переглянути вміст таблиці, ввести і відредагувати дані. У режимі 'Таблица - Конструктор' можна переглянути і змінити структуру таблиці. У режимі 'Таблица - Создать' можна створити нову таблицю.

Для завдання основного режиму роботи треба:

  1. клацнути на кнопці 'Объекты' на панелі Объекты у вікні бази даних;

  2. клацнути на відповідному пункті в списку об'єктів.

^ Створення і видалення таблиць

Щоб включити в базу даних нові відомості, її варто розширити. В одних випадках досить додати запис чи поле в існуючу таблицю, в інших необхідно створити нову таблицю. У Access існує кілька способів створення таблиць. Можна виконати кроки 'Майстра', скористатися 'Конструктором' чи внести назви полів у порожній бланк таблиці.

Для створення таблиці за допомогою "Мастера таблиц" треба:

  1. клацнути на пункті 'Таблицы' у списку об'єктів;

    • клацнути двічі на рядку 'Создание таблицы с помощью мастера' у списку режимів створення таблиць;
      чи

    • виділити рядок 'Создание таблицы с помощью мастера' і клацнути на кнопці 'Создать' на панелі інструментів у вікні бази даних;

    • вибрати рядок 'Мастер таблиц' у списку створення таблиць і клацнути на кнопці 'ОК' у діалоговому вікні 'Нова таблиця';

  2. вибрати категорію таблиці, установивши один з перемикачів:
    Деловые, Личные в діалоговому вікні 'Создание таблиц';

  3. вибрати зразок таблиці в списку зразків;

  4. створити список полів нової таблиці у вікні Поля нової таблиці:, використовуючи один з наступних способів:

    • клацнути двічі на поле, що підходить для нової таблиці в списку Зразки полів:;

    • виділити поле і клацнути на кнопці  
      - поле відобразиться у вікні Поля новой таблицы:;

    • клацнути на кнопці  
      - усі поля відобразяться у вікні Поля новой таблицы:;

  5. виділити поле, яке варто перейменувати, у списку
    Поля новой таблицы: і клацнути кнопку 'Переименовать поле...';
    увести нову назву в діалоговому вікні 'Переименование поля' і натиснути Enter;



  1. клацнути на кнопці 'Далее >';

  2. ввести в поле Задайте імя для новой таблицы: ім'я нової таблиці чи прийняти запропонований варіант у другому вікні 'Мастера таблиц';

  3. вибрати один з варіантів визначення ключа:
    Microsoft Access автоматично визначає ключ
    Користувач визначає ключ самостійно і клацнути на кнопці 'Далее >';

  4. установити зв'язки з наявними таблицями:

    • вибрати таблицю в списку раніше створених таблиць і клацнути на кнопці 'Связи...';

    • задати вид зв'язку в діалоговому вікні 'Связи' і клацнути на кнопці 'ОК';

  5. вибрати один з варіантів дій після створення таблиці:

    • Змінити структуру таблиці - таблиця буде відкрита в режимі 'Конструктора';

    • Увести дані безпосередньо в таблицю - таблиця буде відкрита в режимі 'Таблица';

    • Увести дані в таблицю за допомогою форми, створюваної майстром - буде активізований режим створення форми за допомогою майстра;

  6. клацнути на кнопці 'Готово'

Нова таблиця відкриється в заданому режимі. Вона буде містити всі обрані поля й автоматично додане поле лічильника (якщо був обраний варіант автоматичного визначення ключа). Зв'язок між таблицями можна установити під час створення таблиці і пізніше.

Щоб відкрити таблицю в підрежимі "Просмотр" треба:

  1. клацнути на пункті 'Таблицы' у списку об'єктів у вікні бази даних;

  2. клацнути двічі таблицю у вікні бази даних - таблиця буде відкрита в режимі 'Таблицы' (кнопка 'Вид' на панелі інструментів буде мати наступний вид - ).

Для зміни режиму відображення таблиці треба:

  1. відкрити таблицю в одному з режимів;

  2. клацнути на кнопці 'Вид' на панелі інструментів 'База данных' і вибрати зі списку 'Режим таблицы' чи 'Конструктор';



  1. чи вибрати одну з команд: Конструктор, Режим таблиці в меню Вид.

Для видалення таблиць треба:

  1. клацнути на пункті 'Таблицы' на панелі об'єктів - у вікні бази даних відобразяться всі таблиці;

  2. виділити ім'я таблиці, яку потрібно видалити;

  3. видалити таблицю, використовуючи один з наступних способів:
    ­ натиснути клавішу Delete;
    ­ клацнути на кнопці 'Удалить';

  4. підтвердити видалення таблиці, клацнувши на кнопці 'Да'.


5. Заповнення і редагування таблиць у режимі "Таблица"

Після створення таблиць потрібно внести в них дані. Можна вводити дані безпосередньо в таблицю чи створити Автоформу (Вставка -> Автоформа).

Для введення даних у режимі "Таблица" треба:

  1. клацнути на пункті 'Таблицы' на панелі об'єктів - у вікні бази даних відобразяться всі таблиці;

  2. клацнути двічі на імені потрібної таблиці;

  3. увести дані в комірки таблиці;

  4. зберегти введені дані, клацнувши на кнопці 'Сохранить' на панелі інструментів 'База данных';

  5. закрити таблицю, клацнувши на кнопці 'Закрыть'.

Access завжди пропонує зберегти створені об'єкти чи зміни, зроблені в них перед їх закриттям.

Переміщатися по таблиці під час заповнення можна за допомогою клавіш зі стрільцями на клавіатурі ¬,­, ®, ¯, клавіш  Tab, Enter і клавіш миші. Під час редагування даних можна змінювати висоту рядків і ширину стовпців таблиці.

Щоб змінити висоту рядка таблиці треба:

  • помістити курсор миші на границю рядка в області виділення записів, клацнути ліву клавишу й утримуючи перетягнути границю.

Щоб змінити ширину стовпця треба:

  • помістити курсор миші на праву границю стовпця в області виділення, клацнути ліву клавишу й утримуючи перетягнути границю.

Щоб зручно було переглядати великі таблиці в режимі 'Таблица' стовпці, що містять важливі дані можна закріпити, а стовпці, дані яких у даний момент не потрібні - сховати.

Щоб закріпити стовпець треба:

  1. поставити курсор у потрібний стовпець, клацнувши ліву клавішу миші;

  2. вибрати команду Закрепить столбцы в меню Формат.

Щоб скасувати дію цієї команди, варто вибрати команду Освободить все столбцы в меню Формат.

Щоб сховати стовпець таблиці треба:

  1. поставити курсор у потрібний стовпець, клацнувши ліву клавішу миші;

  2. вибрати команду Скрыть столбцы в меню Формат.

Щоб відобразити схований стовпець треба:

  1. вибрати команду Отобразить столбцы в меню Формат;

  2. вибрати потрібні поля в однойменному діалоговому вікні.


Література.

  1. Гаєвський О.Ю. Інформатика 7-11 класи. -К.: А.С.К., 2003. –с. 32-65.

  2. Информатика. Базовый курс. Учебник для Вузов / Под ред. С.В. Симоновича. –Сакт-Петербург: Питер, 2000. – с. 30-97.

  3. Макарова М.В., Карнаухова Г.В., Запара С.В. Інформатика та комп’ютерна техніка. –Суми: Університетська книга, 2005. – с. 32-69.

  4. Руденко В.Д., Макарчук О.М., Патланжоглу М.О. Базовий курс інформатики. Книга 1. Основи інформатики. –К.: BHV, 2005. – с. 34-96.

  5. Войтюшенко Н.М., Останець А.І. Інформатика і комп’ютерна техніка. –К.: Центр навчальної літератури, 2006. с. 19-53.

Похожие:

Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Перелік питань, що вивчаються. Створення і заповнення бази даних. Об'єкти бази даних База даних
Тема: Вікно ms access. Структура бази даних в Access. Порядок проектування бази даних. Створення нової бази даних за шаблоном
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Лабораторна робота 1 Тема: Проектування та створення реляційної бази даних, як джерела даних для сппр
Мета: Набуття навичок проектування бази даних, що використовуватиметься як джерело даних для сппр
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Тема: Створення бази даних в середовищі субд. Мета
Мета. Навчитись створювати таблиці баз даних, вносити в них дані в режимі таблиць та в режимі форм, експорт даних із Excel
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Питання до екзамену «бд та субд» (гр. 42, 44)
Бази даних та інформаційні системи. Основні поняття.Історія розвитку субд (самостійно)
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\1 наповнення бази даних інформацією, про складські приміщення компанії
Розробіть фрагмент інформаційної системи, що вирішує задачу автоматизації діяльності компанії, що спеціалізується на наданні послуг...
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Опрацювання числових даних. (35)
Типи форматів даних (Числовий, Текстовий, Дата, Час, грошовий, відсотковий тощо )та приклади. (73)
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Тема статистичне спостереження, зведення І групування статистичних даних
Статистичне спостереження – це перша стадія всякого статистичного дослідження, що є науково організованим за єдиною програмою обліком...
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Завдання: обвести номери засвоєних екзаменаційних питань
Загальна характеристика банку даних про педагогічно доцільні технології навчання на уроках математики (Л. Коваль)
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Перелік завдань для курсового проекту з курсу "Організація баз даних та знань"
Книжки та методичні матеріали, рубрикатори по темах, наявність, розміщення, наджодження та вибуття
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\ПР09. 00000І. 007. Озв
Мета: навчитись встановлювати панелі інструментів та закріпити теоретичний матеріал з теми. Відпрацювати навички введення даних,...
Перелік питань, що вивчаються. Створення і заповнення бази даних. Об\Тип уроку: комбінований. Форма проведення уроку
Для створення запитів у різних системах управління базами даних, як правило, використовуються дві основні мови опису запитів
Вы можете разместить ссылку на наш сайт:
Документы


При копировании материала укажите ссылку ©ignorik.ru 2015

контакты
Документы