Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» icon

Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint»


Скачать 43.17 Kb.
НазваниеРеферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint»
Размер43.17 Kb.
ТипРеферат

ГОСУДАРСТВЕННОЕ ОБЗРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ ВЫСШЕГО ПРОФФЕСИОНАЛЬНОГО ОБРАЗОВАНИЯ


«САНКТ-ПЕТЕРБУРГСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ СЕРВИСА И ЭКОНОМИКИ»


КАФЕДРА «Информационные технологиии в сфере сервиса»


РЕФЕРАТ ПО ДИСЦИПЛИНЕ «Информатика»

На тему: «Циклические алгоритмы, Графический редактор Paint»


Выполнил:

студент

1-го курса специальности 190600.62

Рокин Дмитрий Викторович

Проверила:


Санкт-Петербург

2012

Содержание:

Циклические алгоритмы ……………………………………………………....3

Графический редактор Paint ……… …………………………………………5

Программа для вычисления значения функции…………………………….17

Литература……………………………………………………………………..20

Приложения……………………………………………………………………20




Алгоритмы циклической структуры


^ Циклом называют повторение одних и тех же действий (шагов). Последовательность действий, которые повторяются в цикле, называют телом цикла. Существует несколько типов алгоритмов циклической структуры. На рис. 2.1 изображен цикл с предусловием, а на рис. 2.2 - цикл с постусловием, которые называют условными циклическими алгоритмами. Нетрудно заметить, что эти циклы взаимозаменяемы и обладают некоторыми отличиями.

  • в цикле с предусловием условие проверяется до тела цикла, в цикле с постусловием - после тела цикла;

  • в цикле с постусловием тело цикла выполняется хотя бы один раз, в цикле с предусловием тело цикла может не выполниться ни разу;

  • в цикле с предусловием проверяется условие продолжения цикла, в цикле с постусловием - условие выхода из цикла.





Рис. 2.1. Алгоритм циклической структуры с предусловием

Рис. 2.2. Алгоритм циклической структуры с постусловием

При написании условных циклических алгоритмов следует помнить следующее. Во-первых, чтобы цикл имел шанс когда-нибудь закончиться, содержимое его тела должно обязательно влиять на условие цикла. Во-вторых, условие должно состоять из корректных выражений и значений, определенных еще до первого выполнения тела цикла.

Кроме того, существует так называемый безусловный циклический алгоритм (рис. 2.3), который удобно использовать, если известно, сколько раз необходимо выполнить тело цикла.



Рис. 2.3. Алгоритм циклической структуры без условия

Выполнение безусловного циклического алгоритма начинается с присвоения переменной i стартового значения in. Затем следует проверка, не превосходит ли переменная i конечное значение . Если превосходит, то цикл считается завершенным, и управление передается следующему за телом цикла оператору. В противном случае выполняется тело цикла, и переменная i меняет свое значение в соответствии с указанным шагом di. Далее, снова производится проверка значения переменной i и алгоритм повторяется. Понятно, что безусловный циклический алгоритм можно заменить любым условным. Например, так как показано на рис. 2.4.



Рис. 2.4. Условный циклический алгоритм с известным числом повторений

Отметим, что переменную i называют параметром цикла, так как это переменная, которая изменяется внутри цикла по определенному закону и влияет на его окончание.


Графический редактор Paint

Для чего предназначена программа Paint?


Программа Paint— простейший графический редактор, предназначенный для создания и редактирования растровых графических изображений. Он позволяет создавать («рисовать») новые изображения и редактировать уже имеющиеся. Графический редактор Paint ориентирован на процесс «рисования» изображения и комбинирования готовых фрагментов, а не на обработку («доводку») готовых изображений, таких как отсканированные фотографии.

Что такое растровое изображение?


Растровое изображение состоит из отдельных цветных точек, расположенных ровными рядами так же, как на экране монитора. Формирование растрового изображения состоит в задании цвета каждой отдельной точки. Изображение в таком формате очень удобно для отображения на экране компьютера.



Рис. 1 Окно Paint

Каковы основные элементы скна программы Paint?


Большую часть рабочей области окна программы Paint занимает область рисунка. Слева от этой области располагается Набор инструментов с кнопками, соответствующими отдельным инструментам. Если выбранный инструмент имеет дополнительные настраиваемые параметры, панель ниже набора инструментов позволяет производить его настройку. В нижней части окна располагается Палитра, показывающая, какие цвета используются для рисования в настоящее время, и Позволяющая их изменить. Чтобы иметь возможность полностью исполыювать рабочую область окна, эти панели можно отключить через меню Вид.

Какие форматы поддерживаются программой Paint?


Основной формат, поддерживаемый программой Paint, — это растровый формат изображений Windows (тип файла — Точечный рисунок, расширение имени файла .BMP или .DIB). Программа Paint может использовать различные варианты этого формата в зависимости от используемого числа цветов, от монохромного (черно-белою, два цвета) до 24-битового (свыше 16 миллионов цветов). Чем больше цветов в рисунке, тем больше размер создаваемого файла. Кроме этого формата, программа Paint позволяет сохранять графические файлы в форматах Интернета GIF (расширение имени файла .G\F)JPEG (.JPG или .JPEG) и PNG (.PNG) Эти форматы активно используются в Интернете, так как допускают значительное сжатие изображения. Кроме того, программа Paint поддерживает формат TIFF.

Как изменить масштаб изображения?


Программа Paint поддерживает набор фиксированных масштабов изображения, допуская увеличение до восьми раз. Изменить масштаб изображения можно с помощью команды Вид > Масштаб и выбора желаемого масштаба из меню (Крупный масштаб соответствует четырехкратному увеличению, пункт Другой позволяет указать нужный масштаб в открывшемся диалоговом окне). Другой способ изменения масштаба состоит в щелчке на кнопке Масштаб на палитре инструментов. После этого можно указать желательный масштаб на панели настройки под палитрой инструментов или выбрать отображаемую область для четырехкратного .увеличения. При редактировании рисунка в увеличенном масштабе в рабочую область окна, скорее всего, поместится лишь его часть.

Как осуществляется свободное рисование?


Свободное рисование — это метод рисования, аналогичный рисованию на бумаге. Когда художник ведет карандаш по бумаге, появляющаяся линия соответствует траектории движения. Программа Paint содержит три инструмента для свободного рисования: Карандаш, проводящий линию минимальной толщины, Кисть, имеющую определенное сечение, и Распылитель, создающий эффект размытого пятна краски. Рисование производится протягиванием мыши при нажатой правой или левой кнопке. При использовании распылителя эффект зависит не только от траектории движения мыши, но и от скорости движения.

Как выбрать форму кисти?


Форма кисти, а также размер пятна распылителя выбираются на панели настройки под палитрой инструментов. Обратите внимание, что некоторые варианты кисти создают линию разной толщины в зависимости от направления движения указателя мыши.

Как нарисовать прямую линию?


Для рисования прямой линии использую-? инструмент Линия. Рисование состоит в протягивании указателя мыши от начальной до конечной точки отрезка. Толщина линии дается на панели настройки под палитрой инструментов.

Как нарисовать кривую линию?


Для рисования гладкой кривой линии используют инструмент Кривая. Этот инструмент довольно сложен в использовании. Первый этап построения кривой состоит в рисовании прямой, соединяющей ее начальную и конечную точки. Затем эту прямую можно дважды изогнуть протягиванием мыши, причем форма зависит лишь от точки, в которой нажатая кнопка мыши освобождается. Таким путем можно получить даже самопересекающиеся кривые.

Как нарисовать эллипс, прямоугольник, скругленный прямоугольник?


Эти стандартные фигуры получаются использованием соответствующих инструментов (кнопки Эллипс, Прямоугольник, Скругленный прямоугольник). Объект рисуется путем протягивания указателя мыши от одной вершины прямоугольника, охватывающего объект, к противоположной. Стороны прямоугольника (оси эллипса) при таком рисовании всегда параллельны сторонам рисунка. Способ закраски полученной фигуры выбирается на панели настройки.

Как задать ограничения на форму фигуры?


Ограничения на форму фигуры задаются удерживанием при рисовании нажатой клавиши SHIFT. Прямая линия г ли начальный отрезок кривой в этом случае параллельны сторонам рисунка или идут под углом в 45°. Инструментом Эллипс гак i м образом можно получить круг, а рисуя прямоугольник — квадрат.

Как нарисовать произвольный многоугольник?


Для рисования произвольного многоугольника используется инструмент Многоугольник. Первая сторона многоугольника рисуется методом протягивания, далее используются щелчки в последовательных вершинах многоугольника. Для замыкания многоугольника используется двойной щелчок или повторный щелчок в первой вершине многоугольника. Вместо термина «многоугольник» корректнее использовать термин «замкнутая ломаная», так как программа Paint допускает пересечение сторон многоугольника друг с другом.

Как задается цвет, используемый при рисовании?


Программа Paint всегда имеет два текущих цвета, изображенных на левом краю палитры в виде перекрывающихся квадратиков. Цвет в верхнем квадратике считается основным, а в нижнем — фоновым. Если рисование производится при помощи левой кнопки мыши, используется основной цвет, при рисовании правой кнопкой мыши — фоновый.

Как определяется цветовое представление фигуры?


При рисовании замкнутых фигур возможно одновременное использование и основного, и фонового цветов (при использовании правой кнопки мыши они меняются местами). Способ заполнения фигуры определяется выбором одного из трех пунктов на панели настройки. При выборе верхнего варианта рисуется только граница фигуры. Ее внутренняя область остается без изменения. При выборе среднего варианта граница фигуры рисуется основным цветом, а внутренняя область — фоновым. При выборе нижнего варианта и граница фигуры, и внутренняя область закрашиваются основным цветом. Для самопересекающегося многоугольника внутренняя область определяется сложнее, так что он закрашивается в «шахматном» порядке.

Как выбрать текущий цвет?


Текущий цвет можно в любой момент изменить, выбрав нужный из палитры цветов. Щелчок на цветном квадратике левой кнопкой мыши делает выбранный цвет основным, щелчок правой кнопкой мыши — фоновым. Разрешается совпадение основного и фонового цветов.

Как задать цвет, отсутствующий в палитре?


Изображение может включать цвета, отсутствующие в данный момент в палитре цветов, но расширить саму палитру цветов невозможно: надо заменить один из имеющихся цветов новым. Для этого надо дважды щелкнуть на квадратике с заменяемым цветом или дать команду Палитра > Изменить палитру (в этом случае изменяется последний использовавшийся цвет). На экране появится диалоговое окно Изменение палитры, содержащее расширенную палитру. Если в ней нужный есть, следует его выбрать и щелкнуть на кнопке ОК. В противном случае следует щелкнуть на кнопке Определить цвет. Диалоговое окно увеличится ч размере, позволяя выбрать цвет с помощью матрицы и шкалы яркости или задав числовые параметры. После того как нужный цвет получен, то можно сохранить в расширенной палитре, щелкнув на кнопке Добавит в набор, или немедленно использовать, закрыв диалоговое окно щелчком на кнопке ОК. Данный прием задания цвета является общесистемным и используется не только в программе Paint.

Как выбрать цвет по образцу?


Если нужный цвет уже входит в изображение, его можно не конструировать, а взять готовым. Для этого используется инструмент Выбор цветов. Выберите этот инструмент и щелкните в пределах изображения левой кнопкой, чтобы сменить основной цвет, или правой, чтобы сменить фоновый цвет.

Как определить размер и другие общие параметры изображения?


Размер растрового изображения задается как количество цветных точек (пикселов) по горизонтали и по вертикали За счет этого обычно определяется, сколько места займет изображение на экране (эта величина зависит от размера диагонали монитора и экранного разрешения, но обычно на 1 см приходится 30-40 пикселов). Например, картинки экранных значков часто имеют размер 32x32 пиксела. При создании нового рисунка его параметры принимают значение, заданное по умолчанию. Чтобы изменить размер рисунка, используется команда Рисунок > Атрибуты. В диалоговом окне Атрибуты можно задать единицы измерения и размеры изображения, а также указать, должен ли рисунок быть цветным. Щелчок на кнопке По умолчанию указывает, что заданные значения параметров должны по умолчанию использоваться для всех создаваемых в дальнейшем рисунков.

Как изменить размер рисунка а ходе редактирования?


Встречаются ситуации, когда требуется i корректировать размер рисунка на месте, потому что заранее определит! точные размеры в пикселах не представляется возможным. Это можно сделать с помощью маркеров изменения размера, которые располагаются в середине правого края, в центре нижней стороны и правом нижнем углу рисунка. При наведении на такой маркер указатель мыши приобретает вид двунаправленной стрелки. Методом протягивания размеры рисунка можно увеличить или уменьшить. Перетаскиванием углового маркера можно сразу изменить и длину, и ширину рисунка.

Как произвести заливку объекта?


Под заливкой понимается заполнение ограниченной области определенным цветом. Заливка осуществляется с помощью кнопки Заливка в наборе инструментов. Для того чтобы произвести заливку, следует щелкнуть девой или правой кнопкой мыши в месте начала заливки. Закрашиваемая область определяется как множество всех пикселов того же цвета, что и точка начала заливки, связанных друг с другом, то есть позволяющих «добраться» до точки начала заливки движением по пикселам одного и того же цвета. Перед использованием заливки следует убедиться в отсутствии дефектов границы, приводящих к «протеканию краски» в незапланированные области. В случае ошибки надо немедленно нажать комбинацию клавиш CTRL+Z для отмены последней команды.

Как в программе Paint действует операция отмены?


Для отмены последнего выполненного действия в программе Paint используется команда Правка > Отменить или комбинация клавиш CTRL+Z. Повторно выдавая ЭТУ команду, можно отменить до трех последних действий.

Как стереть мелкие элементы рисунка?


Для стирания мелких элементов рисунка удобнее всего использовать инструмент Ластик. На панели настройки под набором инструментов выбирается размер ластика. Стирание ластиком осуществляется так же, как свободное рисование, но допустимо использование только левой кнопки мыши. Очищаемая область заполняется текущим фоновым цветом. Как поместить на рисунок текст? Добавление к рисунку текста производится при помощи инструмента Надпись. Этот инструмент можно активизировать, только когда рисунок отображается в обычном масштабе. При использовании инструмента Надпись сначала надо выделить протягиванием прямоугольную область, в которую требуется поместить текст. В этой области немедленно появится текстовый курсор. Теперь можно начинать ввод текста, примерно так же, как это делается в текстовом редакторе Блокнот. Вводимый текст автоматически переносится по словам на следующую строку. Если высоты созданной области не хватает для размещения всего текста, область автоматически расширяется. Вводимый текст можно немедленно редактировать, используя, в том числе, команды работы с буфером обмена. Для того чтобы закончить ввод текста, следует щелкнуть на документе за пределами области ввода текста или выбрать другой инструмент. При добавлении текста требуется особая внимательность; как только работа с текстом завершена, он превращается в неотъемлемую часть рисунка и дальше может изменяться только на правах изображения.


Как изменить атрибуты текста?


В режиме редактирования текста на экране может появиться дополнительная панель инструментов Шрифты. Если он не появилась, ее можно включить командой Вид > Панель атрибутов текста. Эта панель позволяет выбрать с помощью раскрывающихся списков шрифта и его размер, а также задать начертание — полужирное, курсивное или подчеркнутое.

Каковы особенности нанесения текста в программе Paint?


Так как графический редакторРаint не предназначен специально для ввода текста, изменение атрибутов текста имеет некоторые ограничения. Во-первых, команда изменения атрибутов действует на весь текст в текущей рамке. Ввод текста, имеющего разные атрибуты, производится в несколько приемов. То же самое относится и к цвету текста: вводимый текст изменит цвет при изменении основного цвета, и это относится ко всем символам текста. Обратите также внимание, что при выборе инструмента Надпись включается панель настройки. При выборе верхнего варианта вводимые символы обладают подложкой: они сохраняют удобочитаемость независимо от содержания рисунка, но затирают его фоновым цветом. При выборе нижнего» варианта на рисунок накладываются только символы, изображаемые основным цветом.

Как выделить фрагмент изображения?


Для копирования фрагмента его надо выделить. Программа Paint поддерживает два режима выделения. При использовании инструмента Выделение фрагмент имеет прямей вольную форму и выделяется методом протягивания по диагонали прямоугольника. При использовании инструмента Выделение произвольной области граница выделяемого фрагмента задается методом свободного рисования и даже может иметь самопересечения. После завершения выделения на экране появится прямоугольная рамка, охватывающая выделенную область, но сам выделенный фрагмент имеет именно ту форму, какая была задана.

Каковы особенности работы с выделенным фрагментом?


Выделенный фрагмент можно перетащить в другое место рисунка, поместить в буфер обмена методом копирования или вырезания, преобразовать с помощью команд меню Рисунок. Однако следует учитывать, что есть два механизма для всех этих операций, в зависимости от того, какой вариант выбран на панели настройки под палитрой инструментов. Верхний вариант подразумевает, что фоновый цвет непрозрачен, то есть имеет такие же права, как и другие цвета рисунка. Точки, имеющие фоновый цвет, копируются, перемещаются или преобразуются вместе с остальными точками выделенного фрагмента. При выборе нижнего варианта фон считается подложкой, находящейся под рисунком, так что фоновые точки не копируются вместе с фрагментом. Это удобно использовать при наложении изображений друг на друга. В любом случае удаляемые или перемещаемые точки фрагмента заменяются фоновым цветом.

Каковы особенности вставки фрагмента изображения из буфера обмена?


В отличие от текстового документа, в котором вставка из буфера обмена осуществляется в том месте, где располагается курсор, заранее определить место вставки графического фрагмента невозможно. Поэтому при вставке графического фрагмента из буфера обмена сохраняется его выделение. Это позволяет сразу после вставки произвести перетаскивание объекта в нужное место.

Как «размножить» фрагмент изображения?


Возможность «размножения» фрагмента изображения — это интересная особенность программы Paint. Если производить перетаскивание выделенного фрагмента изображения при нажатой клавише SHIFT, то на траектории перетаскивания периодически появляются копии перетаскиваемого фрагмента. Это очень удобный способ создания орнаментов, набивных рисунков и тому подобных композиций.

Как построить рисунок методом монтажа?


При создании сложных композиций, состоящих из перекрывающихся объектов, удобно использовать метод монтажа, Он состоит в том, чтобы одновременно открыть два окна программы Paint. Одно окно используется для создания отдельных элементов, частей полного рисунка, а другое — для сборки из них итогового изображения. Объекты передаются из одного окна в другое через буфер обмена. Это позволяет подобрать наилучшее положение этих объектов методом проб, без вреда для других частей рисунка.

Как смонтировать рисунок из фрагментов, находящихся в отдельных файлах?


Для вставки на данный рисунок фрагмент сохраненного в виде отдельного файла, используется команда «Правка»

• Вставить из файла. Выбрав рисунок, щелкните на кнопке Открыть. Вставленный рисунок остается выделенным, и его можно переместить в нужное место монтируемого изображения,

Как очистить фрагмент изображения?


Для этого надо выделить фрагмент изображения, подлежащий очистке, то есть заполнению фоновым цветом. Очистка производится командой Правка- Очистить выделение или клавишей DELETE. Если ни один фрагмент не выделен, то команда Рисунок > Очистить позволяет полностью удалить изображение, заполнив всю область рисунка фоновым цветом.

Какие преобразования выделенного фрагмента допускает программа Paint?


Команды меню Рисунок позволяют преобразовать выделенный фрагмент или рисунок целиком. Команда Отразить/повернуть используется для зеркального отображения рисунка относительно вертикальной и горизонтальной оси, а также для поворота на угол, кратный прямому. Команда Растянуть/наклонить позволяет изменить масштаб рисунка (фрагмента), а также произвести сдвиг одного края относительно другого. При преобразовании всего рисунка эта опция изменяет его размер. Команда Обратить цвета превращает рисунок (фрагмент) в негативное изображение.

Какие возможности использования созданного рисунка есть в программе Paint?


Рисунок, созданный в программе Paint, можно немедленно использовать в качестве фона Рабочего стола Windows, Для этого служат команды Файл - Замостить рабочий стол Windows и Файл > В центр рабочего стола Windows. Кроме того, программа Paint предоставляет возможность быстрой отправки рисунка по электронной почте. Для этого служит команда Файл > Отправить.

Задание №3

Тема: Составление и отладка разветвляющейся программы

1. Постановка задачи

Составить программу для вычисления значения следующей функции:




2 Блок-схема алгоритма решения задачи




Рис. 2.5 Блок схема алгоритма решения задачи

3. Текст программы



CLS

^ LOCATE 1, 30

PRINT “Санкт-Петербургуский Государственный университет сервиса и экономики»

REM

INPUT «Введите x»;x

INPUT «Введите a»;a

INPUT «Введете е»;е

IF x
Y=(a+e^x) / (a+e^-x) + (a+x)/1+x^2

ELSE

Y=(a+e^x) / (a+e^-x) + (a-x)/1+x^2

END IF

PRINT «Y=»;Y

END



Рис. 2.6 Окно ввода Basic

4. Результаты вычислений


При X= 5, Е=10, А=15, Y=6668,432

При Х=2, Е=5, А=8, Y=6,104




Рис. 2.7 Окно вывода


Литература:


ПК для чайников, Марк Л. Чемберс 2006

Бэйсик, язык программирования, Перри Грег

Циклические алгоритмы, www.pascaler.ru


Приложения:

1. Программа Paint

2. Программа Basic




Похожие:

Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint»
Государственное обзразовательное учреждение высшего проффесионального образования
Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРасчетно-графическая работа по дисциплине «Алгоритмы дискретной математики»
Найти кратчайшие пути между вершинами графа, используя алгоритмы Дейкстры и Флойда
Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине «Азбука безопасности и выживания человека в экстремальных ситуациях» на тему: «Несколько приёмов преодоления стрессового состояния»
Реферат по дисциплине «Азбука безопасности и выживания человека в экстремальных ситуациях»
Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине: Охрана труда на тему: Мотивация трудоохранной деятельности Студент

Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине «Технология разработки программного обеспечения» на тему: «Моделирование бизнес-процессов»

Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине: клинические основы интеллектуальных нарушений на тему : «Ложная (вторичная), церебропатическая микроцефалия.»

Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине «Э лектрические и электоные аппараты» на тему: «Расположение и типы предохранителей Лады Калины»

Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине: «Радиационная биофизика» На тему: «Методы радиационного экологического контроля окружающей среды»

Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат по дисциплине «ипотечно-инвестиционный анализ» на тему: «тема реферата»
Фгбоу впо «Пензенский государственный университет архитектуры и строительства»
Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconРеферат на тему: Шаблоны в дизайне web-сайтов
Вся графика дизайна шаблона и его служебные файлы (css, Java-скрипты) уже разработаны профессиональным дизайнером, и вам остается...
Реферат по дисциплине «Информатика» На тему: «Циклические алгоритмы, Графический редактор Paint» iconСоздание шкурки в World of Tanks
Для работы Paint. Net на компьютере должен быть установлен. Net framework. Так-же установим плагин DropShadow он понадобится в процессе...
Вы можете разместить ссылку на наш сайт:
Документы


При копировании материала укажите ссылку ©ignorik.ru 2015

контакты
Документы